UbuntuでPlatformIOを使おうとしたときのエラー

ubuntu18.04にPlatformIOを導入しようとしたが、エラーが出て詰まったのでその時の備忘録

Error: Error: Could not create PIO Core Virtual Environment

少し前に今回同様の構成で環境構築したときはすんなりうまく行ったが、今回はこんな感じのエラーが出た。

環境はpython3.6.9が入っているのに、pythonのバージョン関係で怒られるのでそのへんが問題かと思っていたが、結果的に以下の方法でうまく行った

解決法

virtualenvのパッケージをいれるだけ。

sudo apt install virtualenv

エラーレポートをgithubのissueに送信させているようで、大量の検索妨害issueがあってやばい。

handaru

handaru.net

handaru(はんだる)です。 工作が趣味です。

コメント

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です